Ask a Question

ReadyAPI/functional test assertion don't works after awhile!

Occasional Contributor

ReadyAPI/functional test assertion don't works after awhile!


I am using ReadyAPI 3.5.1

I have already defined some test suite and test cases to meet my requirements for test and controlling my API functionality , and it worked fine so i save it and in every new version of my production i try to use already save test cases. 

But funny thing happen! 

I have some simple Assertions in my test cases to control the error messages i expect.

For example i am going to control error message "KEY_UNRECOGNIZED"  , so i had defined an Assertion for response match content and it used to works! but when i try to run the test and control it again after a week , i see that these assertion do not correctly recognize the response error message ! (attached screen capture of it )


So as you can see i supposed to look for "KEY_UNRECOGNIZED" and  in response it has "KEY_UNRECOGNIZED"  and in my case it matched so it supposed to PASS , but i show FAIL ?! 

please note that this test step used to works fine while ago and i have done no change to it ...but it don't works correct now ? 

Community Hero

Hey @Behdad,

Can you add some screenshots to help us visualise the problem please?


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
SmartBear Alumni (Retired)

Thank you for trying to help here Richie!


@Behdad were you able to find out why this is happening?

If you didn't, please provide the Community with screenshots as Richie's asking.

Alternatively, you can go ahead and open a support case.

Sonya Mihaljova
Community and Education Specialist

Occasional Contributor


Many thanks for your reply 

I have recently upgrade to 3.6.1 and as i have changes my test steps, i cant see the issue again , so i am not sure if its solved or not, but let's hope that it won't happen again 🙂



Showing results for 
Search instead for 
Did you mean: