Ask a Question

ReadyAPI LOG4J Upgrade 2.16.0 to 2.17.1

SOLVED
MBoeckler
New Contributor

ReadyAPI LOG4J Upgrade 2.16.0 to 2.17.1

Hello,

 

the current Package ReadyAPI contains LOG4J 2.16.0. 

The Organisation I'm working for requires LOG4J 2.17.1

QUESTION:

Can you tell when ReadyAPI with >= 2.17.1 will be availabe ?

 

Thank You and best Regards 

Marc Boeckler

3 REPLIES 3
richie
Community Hero

Hey @MBoeckler,

You dont have to wait for Smartbear to update the log4j files....you could do it yourself (i did when i heard about the vulnerability a day before they released 3.20.0)

Cheers

Rich
if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

Hello,

thanks alot. Since I'm not so deep in technical issues, could you tell me how to do that ? Is it assured, that there arent any dependencies ?

Anyway, it would be good to know when Smartbear is planning a new 'official' delivery package with new log4j files.

Cheers Marc

sonya_m
SmartBear Alumni (Retired)

Hi @MBoeckler , the libraries were updated in 3.20.1 - https://support.smartbear.com/readyapi/docs/general-info/whats-new.html

 

 


Sonya Mihaljova
Community and Education Specialist

cancel
Showing results for 
Search instead for 
Did you mean: