Ask a Question

ReadyAPI Functional Testing Automate Problem

Occasional Contributor

ReadyAPI Functional Testing Automate Problem

I am writing the test suite for my endpoints.I am having one problem which is for running the 1 test suite twice. For Example, When I add an image with endpoints it adds the Image with a unique Id and returns successfully. This unique Id is generated new every time. So we have another endpoint where we pass unique IDs to delete. So it is successful for the first time but when we run the delete second time the same query then that id is deleted and it says it does not exists. how do we automate this thing? I mean the test case should not fail.

I tried to search but could not able to find any resource, Any help will be appreciated. Thanks.




If it works when you 'hard-code' the id but does not when you 'pull' the value in from a different step, then I can only think something about the second way is wrong.


@richie mentioned that the error number looked odd, e.g. you usually expect a 500 if you pass in an invalid value/payload.  The error is actually a Swagger error.  Now, I have haven't used Swagger beyond creating an account, but it's Swagger saying "No resource that matches the OpenAPI definition".  In other words, it looks like your request is malformed, incorrect, or calling the wrong method etc. when you pull the value in.


Did you try what I suggested above?  SoapUI request steps have a 'raw' tab which shows exactly what SoapUI sent to the API.  Compare what is in the raw tab after sending hard-coded value against what is in the raw tab when you automate.

Occasional Contributor

@ChrisAdams: Thanks for your time. Yes, I looked into the raw request. You were right the value in the URL is not passing correctly but the question is why it is not passing correctly?
I am attaching the raw request with hardcoded and with the selecting property both.
So, now our aim is why it is not sending the correct values when we are selecting from the post method.



Without access as to you test or API, it's really difficult now to help further, sorry.  But, at least you now know why you're getting the Swagger error.

Hey AsadGilani,

The screenshots you attached look like theyre for different APIs (the uris differ). I agree with @ChrisAdams, but if you provided screenshots of the RAW for both requests and responses as well as logging details for any property transfer we mighe be able to help. However without this we're not gonna be able to help.

If you can supply screenshots foe everything we can probably help


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Showing results for 
Search instead for 
Did you mean: