Ask a Question

ReadyAPI: Answer is 200 but no response visible

Regular Contributor

ReadyAPI: Answer is 200 but no response visible


Is there someone who can explain me how I get a Response = 200 but no visible response please?

I can see the response in my webbrowser, why not in ReadyAPI? Is there a configuration that needs to be set?


Thanks in advance,




Community Hero

Hey AboveAndBeyond,

The content length header on your response is 0, so either there is no payload in your response (which i admit would be weird for a GET request) or your query is retrieving zero data.

You say you do the same GET in a browser and youre getting different results?

Can you provide screenshots?
Ive had this before when something wasnt being authenticated/authorised correctly.

Best thing i can suggest.

Id run fiddler to compare what you are sending and receiving when you do the request in a browser compared with readyapi!

Without more detail thats where id start....



if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Regular Contributor

Hi @richie 


Thanks for your answer. I found out what the problem was.

When you look at my screenshot you will see that my Endpoint contains  " beId${#TestSuite#param_beid}  ".

The first 'beId' is somethig that the Endpoint doesn't understand. Well actually, it doesn't find something like

"beId0cf26588-9baa-4a3d-b4bd-981ffbaac28e" so I actually needed to ommit the "beId" and pass the code like this:${#TestSuite#param_beid}

Now it works.


Thanks for you time, Cheers!


Showing results for 
Search instead for 
Did you mean: