Ask a Question

ReadyAPI 3.5.1 - DataSource Test Case - This driver is not configured for integrated authentication

Occasional Contributor

ReadyAPI 3.5.1 - DataSource Test Case - This driver is not configured for integrated authentication


I am using ReadyAPI 3.5.1. version

Before this version I used Soapui Pro 5.1.1 version where the JDBC connection worked normally!

At this program I have sqljdbcauth.dll and sqljdbc41.jar files in this place:



My JDBC connection setting are:


Connection String: 


With ReadyAPI 3.5.1 the same JDBC connection is not working, I get error message:
This driver is not configured for integrated authentication

At this prgram I can not find sqljdbcauth.dll file, only just sqljdbc42.jar file at this place:

C:\Program Files\SmartBear\ReadyAPI-3.4.5\bin\ext

I tried to copy the dll file that i used at SoapuiPro, but the result was the same, i got error massage again


What could be a problem?


Thank you!

Community Hero

Hey @PG,

As far as i was aware the auth.dll handles windows auth and integrated, (integratedsecurity=true), so this issue is a bit of a weird one.

Id redownload both the latest jdbc driver .jar and the auth .dll. and stick them in bin/ext.

Also, are you sure youre using the correct .jar file relative to the sqlserver instance youre trying to connect to? I know sqljdbc42.jar is installed bybdefault with ReadyAPI! install, but when i connected to sqlserver 2016, i had to grab a newer version of driver.....cant remember the file name but it was quite long and definitely not sqljdbc42.jar.

I appreciate it works on SoapUI and youre thinking "shouldnt it work in ReadyAPI! too?" However, the differences between their codesets has been expanding for the last what....5? 6 years maybe? so i wouldnt be surprised if there are inconsistencies between them.


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta



Once additional note to what @richie wrote, when you copied the dll to folder, you need need to restart SoapUI ti pick up new dll files.

Occasional Contributor



I downloaded a from microsoft page, and i copied the mssql-jdbc_auth-8.4.1.x64.dll and the mssql-jdbc-8.4.1.jre8 JAR file in the bin\ext folder, after that i restart ReadyApi but the problem is still living.


Maybe I downloaded wrong package?


My Java version java version "1.8.0_271" 64 bit so I think i copied the correct JAR file.


Where could I download these files?


Thank you!



SmartBear Alumni (Retired)

Thanks Richie, Chris! 


@PG Were you able to solve this? Please share your solution with us.

Or, if you didn't, opening a support ticket is a good next step. 

Sonya Mihaljova
Community and Education Specialist

Occasional Contributor



I found the solution!

I downloaded the from microsoft and copied the mssql-jdbc_auth-8.4.1.x64.dll file into 

C:\Program Files\SmartBear\ReadyAPI-3.4.5\bin


After that I restarted the ReadyApi, and the Datasource connect is working!


Thank you!




Showing results for 
Search instead for 
Did you mean: