Ask a Question

[Ready API 1.2] Double slash (//) in path

Occasional Contributor

[Ready API 1.2] Double slash (//) in path

I get a "double slash" error when calling a REST method using GET. Note that I have lots of other REST calls in my project which do not seems to trigger this bug.

Any idea where the error is coming from and/or how I can identify the cause of the problem ?



Thu Jul 16 13:05:50 UTC 2015:ERROR:nu.xom.MalformedURIException: Double slash (//) in path
   nu.xom.MalformedURIException: Double slash (//) in path
   	at nu.xom.Verifier.throwMalformedURIException(
   	at nu.xom.Verifier.checkPath(
   	at nu.xom.Verifier.checkAbsoluteURIReference(
   	at nu.xom.Element._setNamespaceURI(
   	at nu.xom.Element.setNamespaceURI(
   	at com.eviware.soapui.impl.wsdl.submit.transports.http.BaseHttpResponse.getContentAsXml(
   	at com.eviware.soapui.impl.wsdl.WsdlSubmit.notifyListenersAfterSubmit(
   	at java.util.concurrent.Executors$ Source)
   	at Source)
   	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
   	at java.util.concurrent.ThreadPoolExecutor$ Source)
   	at Source)


The request causing the problem is the following


GET http://myhost:42221/doit HTTP/1.1
Accept-Encoding: gzip,deflate
Host: myhost:42221
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.3.1 (java 1.5)


And the received answer contains this:


HTTP/1.1 200 OK
Content-Type: application/json
Content-Length: 13





Hello You  post the question a few days ago, I read many replies, but i did not find the solution. Do you solve it now?

I'm just ignoring the error on TeamCity - Making it look As a warning and the test passes .


Occasional Contributor

I fixed this issue by going through the suite xml file. Search for any trailing / or // in between URL and fix that. You can use notepad++ to find all the instant. I used \w// pattern and /< pattern to find trailing / or // in between URL.


Hope this helps for the time being.

Thank you RiteshY, I have found the double slash and solved problem.

Occasional Contributor

This should be the official workaround for this problem as for now. Thx.

Occasional Contributor

I had the same problem, and I solved by delete // from project file.

Below I describe my case, maybe it will help you to fix it.

I have base edpoint /api/dashboard/processes-summaries/{processId}/change-pin-state

But this endpoint was added to the project as


{processId} have been cut from the uri, that's why this error happens.

Yes able to fix the double slash issue. Opened the project in an editor and searched for // in between my endpoint url.

Finally fixed it. It's not something soapui need to fix.

Showing results for 
Search instead for 
Did you mean: