Ask a Question

Integration tab shows "Browser Component is disabled"

Occasional Contributor

Integration tab shows "Browser Component is disabled"

ReadyAPI 3.6.0

Integration tab shows "Browser Component is disabled"


Log: ERROR: An error occurred [com.teamdev.jxbrowser.engine.ChromiumProcessStartupFailureException: Failed to initialize the Chromium process], see error log for details

Community Hero

Hey @kiwi23,

This error is being reported in the ReadyAPI log or the error that correct? If not...where is this error text beinf displayed?

When are you seeing this error, what are you actually this when you start ReadyAPI?

Is the generation of this error hindering you from doing what you need to?

Do you need the built in browser for anything that you are doing? Im just wondering....ive never used the browser in my years using ReadyAPI. If its disabled, is this a real problem or can you carry on despite this issue being generated?

I know some people have had problems and theyve had to disable the browser, so the browser not working correctly isnt necessarily a problem (well...unless either you need it, or ita hindering your work in some way)


if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Occasional Contributor

Thanks for the reply




I am trying to find ways to integrate readyAPi with teamcity

Also I am pretty new to this tool.


Occasional Contributor

We're having the same issue with the latest ReadyAPI version (3.10.0), but also older versions like 3.5.1.

Support ticket has been made: 00493046


Thanks for contacting the SmartBear support team.I can reproduce the issue with ReadyAPI 3.10.0 and our test Bitbucket Cloud account, as well. A bug RIA-18398 has been created for that.I will let you know when I have any updates from our developers regarding the matter. Sorry for the inconvenience.Regards,
Julia Kolosova
Customer Care Engineer

Occasional Contributor

Thank you.

Occasional Contributor

Did you able to sort this issue.

I am still having the same issue

Occasional Contributor

Nope... after update 3.10.1 still not solved (in ReadyAPI).
Hopefully next update.

Occasional Contributor

Thank you... will wait for it

Hello ,

I am in 3.20.1 and still seeing the issue -Browser Component is disabled. Any idea when it will be fixed.

SmartBear Alumni (Retired)

Hi all!

The browser issue is related to the JxBrowser component used by ReadyAPI, and can be caused by a number of reasons. Bug RIA-18398 mentioned by @davinci020 was connected mainly to BitBucket Cloud integration errors, the "Browser component is disabled" issue was just a side one.

These are tips and tricks which you can try to overcome the "Browser component is disabled" error in the Integrations page:

1. Delete the "-Dsoapui.browser.disabled=true" option if any from the ReadyAPI.vmoptions file.
2. Try running ReadyAPI with and without the Administrator's rights.

3. Try installing the plugins manually by following the instructions specified in the FAQ article.

If this does not help, please submit a new case here and we will continue the investigation within the case.


Customer Care Team

Did my reply answer your question? Please give Kudos or Accept it as a Solution to help others.
Showing results for 
Search instead for 
Did you mean: