Ask a Question

How to set user agent when executing Ready APi project on jenkins( unix)


How to set user agent when executing Ready APi project on jenkins( unix)

i was able to Use the Ready API client using preference i was able to set the User Agent. But when i execute the project(mavenzied) on jenkins .User Agent default going as empty.

Community Hero

Hey @harry 



I've done a little reading I think this isnt a ReadyAPI issue but a Jenkins or build agent issue.  I'm assuming manually hard coding the User-Agent header in ReadyAPI is equivalent to using the User-Agent header flag in the Preferences.


One of the sites I found suggested setting the http.agent system property on the command line when launching Jenkins.


Unsure if that'll help or not - but worth a look maybe?





if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta

I have copied the soapui-settings.xml from my local to jenkins machine. I can see the user agent working.  we have different usescases where we need to test with different values HttpSettings@user-agent with different values ( Android, IOS,Ipad) How can i set it programmatically? right now i was able to set with only Android. Other testcases were failing.

Showing results for 
Search instead for 
Did you mean: