Ask a Question

How to disable Transfer-Encoding: chunked

ECiurleoIOP
Occasional Contributor

How to disable Transfer-Encoding: chunked

I am sending a request with a zip attached to an (ancient) endpoint that doesn't accept chunked transfers encoding.

 

The request is below with the some information redacted;

 

POST http://xxxxxx.xxxx/article HTTP/1.1
Accept-Encoding: gzip,deflate
Content-Type: application/zip
Authorization: xxxxxxxxx
Transfer-Encoding: chunked
Host: xxx.xxx.xxx
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.5.2 (Java/1.8.0_77)
<request data not available>

It appears that I need to disable chunking for HTTP requests.

 

I have attempted to change Preferences-->HTTP-->Chunking Threshold to the following values

 

0

-1

1

999999999

 

but Transfer-Encoding: chunked is still in the generated request.  How do you remove this header from the requests?

 

cancel
Showing results for 
Search instead for 
Did you mean: