Forum Discussion

Andreas_Schmidt's avatar
New Contributor
3 years ago

Disable chunk transfer-encoding does not work

I´m on SoapUI 5.5.0 and try to test an jpg-image upload to a nextCloud - Server (WebDAV). It works with Postman, but uploading with SOAPUI results in an 0 byte file on nextCloud. The only difference between Postman- and SOAPUI- Request I see is the different transfer-encoding: SOAPUI  chunks the binary data - Postman doesn´t. Although this is obviously a nextCloud (or Apache/PHP) - issue....


How can I force SOAPUI not to chunk the binary data? The same issue raised up in - with no satisfying solution. The hint "setting chunking threshold to "blank" (I aslo found some older hints setting it to 0 or -1) or setting nit to a very high value has no effect... 








2 Replies

  • richie's avatar
    Community Hero
    Hey Andreas_Schmidt,

    I was gonna say "change the setting to zero", but youve already tried that.

    I thought chunking was disabled by default in soapui....

    Can you attach the RAW details of your successful Postman request and also attach the RAW of your SoapUI request?

    We need to see the headers from both if thats ok?