Ask a Question

Groovy custom vmoptions not loaded

New Contributor

Groovy custom vmoptions not loaded

I'm importing an external jar that requires some runtime options so I added them to the .vmoptions file (and I did have an extra white line at the end) 




But it doesn't seem to be taken...

==> ERROR [UDPServiceImpl] init(); 0; Can't start because of error: Invalid UDP port: -1 (should be 7000)


When I run that jar from IntelliJ with those VM options I see port = 7000.


Is there a way in groovy to print the value of JAVA_OPTS (vmoptions) to validate the arguments used at runtime? Am I doing something wrong?



New Contributor

I did a small test['']); ==> com.smartbear.ready.ReadyApiSecurityManager['jmx.address']); ==> null


For all -Dvariables that I added I get null when I run that in groovy. I did restart ReadyAPI after modifying the vmoption file.

SmartBear Alumni (Retired)

Community, is there anything we can suggest here?

Tanya Yatskovskaya
SmartBear Community and Education Manager

Not just for your properties, even some pre-existing ones are also not reproducible.

By the way, you can see what are available using Menu -> Help -> System Properties

To address your problem, you can add them to soapui.bat / .sh (similarly required in testrunner utility as well if you are running the test command line)

Add them in JAVA_OPTS as shown in the below thread:

NOTE: have a backup of the original scripts before making the suggested change.

Showing results for 
Search instead for 
Did you mean: