Ask a Question

File path to Reports throw error

Occasional Contributor

File path to Reports throw error


I would really appreciate some help on this.

i am trying to run ReadyAPI from Microsoft ADO pipeline as "Command Line" task.

When running directly from the server, everything is working fine. but when iam running as ADO Command Line job, it is throwing error (Access is denied)


i have verified the existence of the directory and the access.


Error log:

2020-08-18T20:16:18.6215099Z 16:16:18,590 INFO  [WsdlProject] Loaded project from [file:/C:/Repos/DEX%20Automation/SoapUI/Projects/MB/MB-Regression-readyapi-project.xml]
2020-08-18T20:16:19.0387457Z 16:16:19,021 WARN  [SoapUIProGroovyScriptEngineFactory] Missing scripts folder [C:\Program Files\SmartBear\ReadyAPI-2.6.0\bin\scripts]
2020-08-18T20:16:19.8153187Z 16:16:19,796 INFO  [SoapUIProTestCaseRunner] Running tests in the project [MB Regression]
2020-08-18T20:16:19.9043796Z 16:16:19,899 INFO  [SoapUIProTestCaseRunner] Running TestCase [eForm - Lease]
2020-08-18T20:16:19.9134132Z 16:16:19,912 INFO  [SoapUIProTestCaseRunner] Running TestCase [eForm - Lease]
2020-08-18T20:16:20.3083347Z 16:16:20,291 INFO  [DBDataSource] Retrieved 34 columns from the result set
2020-08-18T20:16:20.3110962Z 16:16:20,292 INFO  [SoapUIProTestCaseRunner] running step [DataSource]
2020-08-18T20:16:20.4066108Z 16:16:20,364 INFO  [DBDataSource] Retrieved 34 columns from the result set
2020-08-18T20:16:20.7955905Z 16:16:20,781 ERROR [SoapUIProTestCaseRunner] Error saving failed result: C:\Program Files\SmartBear\ReadyAPI-3.2.5\bin\CDK-eForm__Lease-DataSource-0-PASS.txt (Access is denied)
2020-08-18T20:16:20.7958215Z C:\Program Files\SmartBear\ReadyAPI-3.2.5\bin\CDK-eForm__Lease-DataSource-0-PASS.txt (Access is denied)
2020-08-18T20:16:20.7959605Z 	at Method) ~[?:?]
2020-08-18T20:16:20.7960559Z 	at ~[?:?]
2020-08-18T20:16:20.7962203Z 	at<init>( ~[?:?]


thanks in advance for the help


Community Hero

Hey @JayKrish 


I dont know whether this will help cos I had the same issue when running testrunner GUI - it might be the same - it might be different.  I dont know enough about what youre doing to determine if youre actually using the testrunner config or not......


Anyway - I had the same access denied FileNotFoundException (and even raised a query about it) and I found out it cos my 'Reports' tab wasn't configured correctly.


What does it say in your 'Root Folder' editable field? - when this was blank - I got the same behaviour you are reporting.


See link




I've running 3.3.0 and I just noticed that %WORKSPACE%, which is what it says to use on the link I supplied - wasn't resolving the correct path - so you might want to look at hardcoding this instead if its the same behaviour in whatever version of ReadyAPI! you're using.

Actually Im finding a number of issues with my testrunner - it worked on previous versions.


Anyway - hopefully this will help a bit.





if this helped answer the post, could you please mark it as 'solved'? Also if you consider whether the title of your post is relevant? Perhaps if the post is solved, it might make sense to update the Subject header field of the post to something more descriptive? This will help people when searching for problems. Ta
Occasional Contributor

You are right. i was changing the arguments that i was passing one by one and when updated the reports path, it actually stopped throwing this Access denied error. i wasn't sure why that happened, now that you have clarified.


Thanks a lot.


Showing results for 
Search instead for 
Did you mean: