Ask a Question

Error with report generation

alibaba82
Super Contributor

Error with report generation

Hello,
I am using luntbuild to automate my testing process. I have defined various command builders to be used in a schedule. A typical command build will look like this.

cmd.exe /C testrunner.bat "C:\Workspace\Automation\soapUI_Scripts\Phase2.5\Integration_Environment\UserProfileService\UserProfileService_Reorganzied-soapui-project.xml" -f"${build.artifactsDir}\UserProfileService" -j

all the results will be written to some directory. After all the results are done, I parse through the 'report.xml' file that soapui generates and calculate various stats and send out an email. My code basically iterates through all the testsuites elements and calculates pass% bass the different attributes in the testsuite element.

The issue is that sometimes this report.xml does not get written correctly (please see the attachment in your email) which inturn causes problems with my calculations. I am trying to figure out why does this happen.

Thanks

Ali

I am sending the incorrect report.xml and the buildlog from luntbuild.
2 REPLIES 2
omatzura
Super Contributor

Re: Error with report generation

Hi Ali,

hmm.. there is an error in the generated file, so it seems like a bug in the report generation.. do you have a reproducible scenario or does it seems random..?

sorry for the inconvenience...

regards!

/Ole
eviware.com
alibaba82
Super Contributor

Re: Error with report generation

seems random. I ran the same schedule in luntbuild yesterday and it worked fine. It broke today for some reason. I'll try it out a few times again and hopefully times and will let you know if its quite frequent.
cancel
Showing results for 
Search instead for 
Did you mean: