Ask a Question

DispatchException: Missing operation for soapAction -Weblogic 12c SOAPUI

shrivastava_ira
New Contributor

DispatchException: Missing operation for soapAction -Weblogic 12c SOAPUI

I deployed SOAPUI project as war in weblogic12c. When am sending the request the first time, the deployed service is giving me the correct result. Next time when I am trying to post the request to the same URL its not giving me any response back instead I am seeing below issue in diagnostic logs. Please help. 

I am attaching the latest project and file. also attaching logs for your reference. 
[ERROR] [] [com.eviware.soapui.mockaswar.MockAsWarServlet] [tid: [ACTIVE].ExecuteThread: '2' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: ba23edd2-b42e-406c-8943-1872a828b2d2-00020676,0] [APP: ApplicationServiceTest] [[ 
com.eviware.soapui.impl.wsdl.mock.DispatchException: Missing operation for soapAction [http://dhcs.ca.gov/services/application/createnew] and body element [{http://dhcs.ca.gov/services/application}CreateNewApplicationRequest] with SOAP Version [SOAP 1.1] 

4 REPLIES 4
Nastya_Khovrina
Moderator

Re: DispatchException: Missing operation for soapAction -Weblogic 12c SOAPUI

Hi Ira,

 

Thank you for your post! But, I don't see the attached project file. But, based on "DispatchException: Missing operation for soapAction", I suppose that you didn't specify the response for one of the Saop Actions. You can compare the first and second raw requests.

 

Please see the attached files and the "SOAP Virtual Services" article for details. 



Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
shrivastava_ira
New Contributor

Re: DispatchException: Missing operation for soapAction -Weblogic 12c SOAPUI

Hi Anastasia,
I am using 'Deploy as war' feature of SOAPUI version 4.6.3 for creating WAR for mockservice (having groovy script for determining the response). This war when I am deploying on tomcat working expected and giving right results every time to me. It works fine when SOAPUI hosted the mock webservice but I have a tough time trying to get the deployment of the war file using weblogic12c to work. The mock webservice would work the first time on the server but subsequent requests get a blank response.
Attaching war file:
1. SOAPui project
2. Raw xml request screenshot for request and response.

Raw xml of success response and No response data has Content-length header different. But I am not sure why because I am posting the EXACT SAME request in both of them.

Please help !!!!!

dpradeep27
New Contributor

Re: DispatchException: Missing operation for soapAction -Weblogic 12c SOAPUI

HI Shrivastava,

 

Did you get this issue resolved? am facing the same issue...can you guide me on how to get this resolved...

Nastya_Khovrina
Moderator

Re: DispatchException: Missing operation for soapAction -Weblogic 12c SOAPUI

Do you use SopaUI Open Source? Did you try the same in the latest version of ReadyAPI which is 2.4 now?



Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️
cancel
Showing results for 
Search instead for 
Did you mean: