Ask a Question

Datasource values blank on Linux

jmueller
New Contributor

Datasource values blank on Linux

Hello,

I am using SoapUI NG Pro, and I have been changing the project I work with from using a groovy test step that call methods that read a csv file to just using a Datasource test step. This works fine on the Windows machine I am developing my test on. The datasource and following HTTP request work as expected. When I transfer the project file and csv file to a headless Linux machine (which has more resources for load tests) it seems as though the query paramater's value is now blank. There is a need to change the filepath in the project's xml to fit the Linux filepath scheme, but I have done that. Is there anything else I need to do or any other reason this would be happening?

I have tested that this occurs on Ready API 1.5 and 1.7.

I also saw this post https://community.smartbear.com/t5/SoapUI-NG/TestSuite-Data-not-passed-from-Data-Source-to-Request-X... but I thought I would get a response faster by making a new post since activity was moved away from that one.

 

Thanks

1 REPLY 1
TanyaYatskovska
Community Manager

Re: Datasource values blank on Linux

Hi Jmueller,

 

In the thread you mentioned, the issue was related to the fact that Property Expansions weren’t filled in. Could you please check that in your project on Linux?

https://www.soapui.org/data-driven-tests/functional-tests.html

https://www.soapui.org/working-with-soapui/point-and-click-testing/point-and-click-with-xpath.html

---------
Tanya Yatskovskaya
SmartBear Community and Education Manager


cancel
Showing results for 
Search instead for 
Did you mean: