Ask a Question

Why did my steps not separate into their own "step" after importing a CSV file?

SOLVED
sheba0907
Occasional Contributor

Why did my steps not separate into their own "step" after importing a CSV file?

I imported a CSV file from Excel.

In the Excel spreadsheet, (before converting to CSV), all my steps were in one cell with a carriage return after each step so that each step would display on its own line inside the cell. 

During import, I chose Step_Steps so that each step would be its own "step"

But that didn't happen. 

All 5 steps were listed as 1 step after import. 

What did I do wrong?

 

Sheilagh
1 ACCEPTED SOLUTION

Accepted Solutions
Nastya_Khovrina
Moderator

Re: Why did my steps not separate into their own "step" after importing a CSV file?

Hi Sheilagh,

 

There are two different CSV layouts that can be imported, controlled by a system setting: one where each row represents a single test, with Steps in one cell, or one where each row represent a step within a test (Importing and Exporting Tests). It looks like, currently, you have the second one. So, you can modify your imported CSV file, or change the import profile.

 

If you use On-Premise edition of QAC, you may change the import profile in System Preferences

To change the import profile setting, click Setup at the upper right of the menu bar and go to System Configuration > System Preferences. Use the Quick Search to find "ImportTestSteps-LineBreaks" in the Code field. Change the value from N to Y.

 

If you use SaaS edition of QAC, please contact Support to change the import profile.

 


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

1 REPLY 1
Nastya_Khovrina
Moderator

Re: Why did my steps not separate into their own "step" after importing a CSV file?

Hi Sheilagh,

 

There are two different CSV layouts that can be imported, controlled by a system setting: one where each row represents a single test, with Steps in one cell, or one where each row represent a step within a test (Importing and Exporting Tests). It looks like, currently, you have the second one. So, you can modify your imported CSV file, or change the import profile.

 

If you use On-Premise edition of QAC, you may change the import profile in System Preferences

To change the import profile setting, click Setup at the upper right of the menu bar and go to System Configuration > System Preferences. Use the Quick Search to find "ImportTestSteps-LineBreaks" in the Code field. Change the value from N to Y.

 

If you use SaaS edition of QAC, please contact Support to change the import profile.

 


Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

cancel
Showing results for 
Search instead for 
Did you mean: