Ask a Question

How to start Collaborator automatically after reboot on RHEL 7

SOLVED
rosse
New Contributor

How to start Collaborator automatically after reboot on RHEL 7

Hello, I am fairly new to Linux and I need to set up our Collaborator instance to start automatically after a reboot. We are using Red Hat Enterprise Linux 7.9 and I can't figure out how to achieve this, I see in the documentation: https://support.smartbear.com/collaborator/faq/how-to-configure-the-collaborator-server-to-start/  that there is a very brief mention on how to do this: 

  • The installation directory of the Collaborator server contains the "ccollab-server" file that can accept the usual "start" and "stop" commands. You can create a symbolic link to this file from your standard installation directory to force the server to start automatically upon system startup.

I have tried creating this link in /etc/systemd/system but doesnt seem to do anything, I tried create a basic script that just calls /PathToApplication/ccollab-server start and that does not work. I tried creating a .service file which executes ccollab-server start.  I can't find any helpful errors on the host and whenever I never see any entries in the collaborator error log, if i would at least get errors I could validate that my script was at least attempting to start the service. 

 

Is there anymore guidance on this other than what is in that documentation, a step by step guide or video?  Thanks, feeling dumb!

2 REPLIES 2
ed_mason
Regular Visitor

Here is what we use on RHEL, assumes you are using mysql

Create a startup script 

/etc/systemd/system/ccollab.service

 

[Unit]
Description=Collaborator_Startup
After=mysql.service

[Service]
Type=oneshot
ExecStart=<path to your installation>/ccollab-server start
ExecStop=<path to your installation>/ccollab-server stop
User=<user account you run collaborator with>
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target

 

Set permissions on script

chmod 755 /etc/systemd/system/ccollab.service

 

Enable the script

systemctl enable ccollab.service

 

Start the service

systemctl start ccollab.service

 

rosse
New Contributor

thank you so much, worked! I had some of those config settings but not all, I must have missed some that made the difference. Much appreciated!

cancel
Showing results for 
Search instead for 
Did you mean: