cancel
Showing results for 
Search instead for 
Did you mean: 

fix HTTP Header Separator from "," to ";"

0 Kudos

fix HTTP Header Separator from "," to ";"

Hi

 

when I add Custom Header to a script, via the "Custom Headers" -> Add

 

and it is called Cookie with "Header Options" = "Merge Values"

 

it indeed ads a cookie to each request of the script, unfortunately, it merges it with the other cookies that are set by the server with separator "," instead of the standard separator ";"

 

e.g. the final Cookie strings looks like:

 

Cookie: JSESSIONID=xJf3R5S-YXoNAMUgxD2wzw__.flir-prod-com2*;*
optimizelySegments=%7B%222070250466%22%3A%22direct%22%2C%222073540371%22%3A%22ff%22%2C%222075260151%22%3A%22false%22%7D*;
*optimizelyEndUserId=oeu1442258291821r0.7898720592969987;
optimizelyBuckets=%7B%7D*;* optimizelyPendingLogEvents=%5B%5D*, *
X-Backend=node1
please note that I have added the Cookie: X-Backend=node1 to the string by setting the "Custom Headers"

 

this is also documented in ticket - Case #00131956

 

also see attached screenshot

 

many thanks

 

-Duro