cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to login web application with ReadyAPI

YanNguyen
New Contributor

Unable to login web application with ReadyAPI

 

Hi guys,

I try some simple requests to login to my web application

Steps:

Get Login page to retrieve __RequestVerificationToken (with Property Transfer)

Then can Login Post method to Login my web application

 

But response is always 'An error occurred while processing your request'

 

See an attached file for more details

 

Any ideas to fix this issue

6 REPLIES 6
joejoyce
Staff

Re: Unable to login web application with ReadyAPI

Hi @YanNguyen. Is the attached XML from the error logs? Where is that file from?

 

Also, would it be possible to attach a screenshot of the failed request and subsequent response?

YanNguyen
New Contributor

Re: Unable to login web application with ReadyAPI

 
 

Here is log file and screenshot my steps

@joejoyce 

 
 

YanNguyen_0-1618489114668.png

 

joejoyce
Staff

Re: Unable to login web application with ReadyAPI

Thanks. So it looks like the server is returning a 500. Are you able to get a successful response from the server using the same request from a different application/client? Is this your first time testing it in ReadyAPI, or has it worked before and now started failing?

YanNguyen
New Contributor

Re: Unable to login web application with ReadyAPI

 
 
 

Sorry, our test server auto shutdown in last night

 

I did try in this morning but still not able to login with ReadyAPI

This function still work well with Jmeter or Selenium but not SoapUI and ReadyAPI (see attachment)

 

YanNguyen_0-1618538737190.png

 

I just think that may be lead to the problem is the parameter which I sent to server (__RequestVerificationToken), it have some special charaters in the name

 

YanNguyen_1-1618538921934.png

 

I'm just on the way to research best load testing tool to apply to our project (newbie), so please help me check this problem again

 

Thanks

YanNguyen
New Contributor

Re: Unable to login web application with ReadyAPI

 
 

Hi @joejoyce 

 

Any other informations about that

I still not able to login to out website with that problem

joejoyce
Staff

Re: Unable to login web application with ReadyAPI

Hey @YanNguyen. You mentioned that you thought the issue may be caused by special characters in the token. What kind of characters are we talking about? Unicode, or some other format?

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors