cancel
Showing results for 
Search instead for 
Did you mean: 

Ready API 2.2.0 crashes silently

SOLVED
sriramd
Occasional Contributor

Ready API 2.2.0 crashes silently

I'm using ReadyAPI v2.1.0 and updated the version into v2.2.0. since then the readyAPI tool is getting crashed silently. Every time the tool gets crashed, a File named "delete" is created in the Users\.readyapi\logs. the content of file as follows

 

"Starting to delete 4 files [C:\Users\*\AppData\Local\Temp\84a7c025-dc37-45f4-9c8a-c17efa182290, C:\Users\*\AppData\Local\Temp\bf8a0823-35e9-467a-b9eb-4ee8ffb89f05, C:\Users\*\AppData\Local\Temp\9339c96d-c4af-414b-ac57-3d44fbe940ae, C:\Users\*\AppData\Local\Temp\838beeb7-b9a9-46d0-9f56-ad6fa8a55613] at Thu Jan 18 16:17:13 IST 2018
Done - actually deleted 4 files and directories
Exiting at Thu Jan 18 16:17:13 IST 2018"

1 ACCEPTED SOLUTION

Accepted Solutions
avidCoder
Super Contributor

Re: Ready API 2.2.0 crashes silently

Hi,

 

Try to change the Xmx and Xms value in ReadyAPI-2.2.0.vmoptions file.

Path for the file is  : C:\Program Files (x86)\SmartBear\ReadyAPI-2.2.0\bin

 

Please find the below link for more information : https://support.smartbear.com/readyapi/docs/testing/best-practices/memory-usage.html

 

Regards

ashutoshanshu

View solution in original post

5 REPLIES 5
avidCoder
Super Contributor

Re: Ready API 2.2.0 crashes silently

Hi,

 

Try to change the Xmx and Xms value in ReadyAPI-2.2.0.vmoptions file.

Path for the file is  : C:\Program Files (x86)\SmartBear\ReadyAPI-2.2.0\bin

 

Please find the below link for more information : https://support.smartbear.com/readyapi/docs/testing/best-practices/memory-usage.html

 

Regards

ashutoshanshu

View solution in original post

sriramd
Occasional Contributor

Re: Ready API 2.2.0 crashes silently

ReadyAPI.vmoptions file has the -xmx value is 4000m and -xms value is 128m. And i am using 8GB RAM memory CPU. which value do i need to change the XMX value in the ReadyAPI.vmoptions file ?

avidCoder
Super Contributor

Re: Ready API 2.2.0 crashes silently

Set Xmx to 8192 MB. And restart ReadyAPI again,  and I am using 16 GB RAM.. ReadyAPI uses 4 GB RAM actually.

 

Here is the link to understand the keywords :- https://support.smartbear.com/readyapi/docs/configure/advanced/jvm-options.html

sriramd
Occasional Contributor

Re: Ready API 2.2.0 crashes silently

I'm using 8GB RAM, can I set xmx value to 8192 MB?. If not which value do I need to set?

avidCoder
Super Contributor

Re: Ready API 2.2.0 crashes silently

Actually 4000 MB is absolutely fine for 8 GB RAM.. It shouldn't crash. But you could give a try to increase it to 8192 MB. Hope it works.

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors