cancel
Showing results for 
Search instead for 
Did you mean: 

Launch ReadyAPI! In Debug Mode By Default

SOLVED
Highlighted
Occasional Contributor

Launch ReadyAPI! In Debug Mode By Default

This used to work by entering the following line into the readyAPI.vmoptions file:

-agentlib:jdwp=transport=dt_shmem,suspend=n,server=y

 

Since the 3.1 update I am not able to debug in Groovy scripts anymore.  I was hoping 3.2 fixed it but it is still not working for me.  Is there some other setting I need to be aware of? I've looked all over and everything pertains to much older versions of SoapUI.

 

Thanks!

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Manager

Re: Launch ReadyAPI! In Debug Mode By Default

Thank you for the advice, Rao!

 

Hi @khanchett! This help topic, explains how to enable debugging permanently. If this doesn't work as listed in the doc, it's an issue. To fix it, please submit a support ticket to the Support team.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

2 REPLIES 2
Highlighted
Community Hero

Re: Launch ReadyAPI! In Debug Mode By Default

You may want to check with Smartbear customer service with a ticket for quick resolution if you think that broke in recent versions.



Regards,
Rao.
Highlighted
Community Manager

Re: Launch ReadyAPI! In Debug Mode By Default

Thank you for the advice, Rao!

 

Hi @khanchett! This help topic, explains how to enable debugging permanently. If this doesn't work as listed in the doc, it's an issue. To fix it, please submit a support ticket to the Support team.


Sonya Mihaljova
Community and Education Specialist

Did my reply answer your question? Give Kudos or Accept it as a Solution to help others. ⬇️⬇️⬇️

View solution in original post

New Here?
Join us and watch the welcome video:
Announcements
Top Kudoed Authors