Forum Discussion

ssatelle's avatar
New Contributor
2 years ago

Are the Zephyr apairy api docs broken or out of date?

I'm using


when I try to GET :




(the base url is my server url up the /latest slug )


I get a 415 unsupported media type. 


I know the treeid is correct, both from clicking into the folder in the browser and seeing <snip>/flex/html5/tcr/25870;treeId=139397;testcaseId=2<snip> and from using the Get Project Repository Testcase Tree by projectid endpoint 




 and seeing the id in the list


What I'm trying to do is to get a list of all test cases by phase, in multiple projects in their Project Test repository's




3 Replies

  • Hello Ssatelle,


    Yes you could get by the above API and the above API is working fine I could see you have used the wrong URL the complete URL should be like this






    • ssatelle's avatar
      New Contributor

      My base url is defined as:



      so the query I'm running is :




      And the response is  a 415 error which means
      The HTTP 415 Unsupported Media Type client error response code indicates that the server refuses to accept the request because the payload format is in an unsupported format. The format problem might be due to the request's indicated Content-Type or Content-Encoding , or as a result of inspecting the data directly.


      I have no body in the request (it's  a GET request anyway) and I also tried with Content-Type application/json with the same result