Forum Discussion

RichBopp's avatar
4 years ago

Since Upgrading to 14.72.408 - We can no longer run our Mobile Keyword Scripts

Since Upgrading to 14.72.408, we can no longer run our Mobile Keyword scripts.

We are on Chrome x86, and have used Chrome's device emulator to test as iPhoneX. Was working fine when we were on 14.70.237.

Now if we run a script, we get a "There was an attempt to perform an action at a point, which is beyond the screen" error.

Chrome's 'Inspect Element' tool has no issue differentiating the objects on the screen. However TestComplete's Object Spy can no longer do the same. - SEE Attached Video.

When we turn the device emulator off - then the Object Spy works - but then we're not testing the iPhone any more. - SEE Attached Video.

We are not seeing an issue when testing in WEB.

Did the upgrade overwrite a Setting? Is there an issue with Chrome?



6 Replies

    • tphillips's avatar
      Frequent Contributor

      It might also be worth doing a fresh installation, somethimes that fixes things for us 🙂

  • ApplePen's avatar
    Community Leader


    I'm back!

    I try it again in TestComplete 14.70.237.

    Sadly I still cannot capture the object with Object Spy.😅


    If it worked in your side with 14.70.237, the reason of the problem maybe the Chrome version.


    Even though , you cannot capture or operate the element in the page.

    You could do the action with dom. Like below code instead of using namemapping object.





    • RichBopp's avatar

      Thank you all. 

      First - correction - we are on Chrome 88 not 86.  My bad.


      Second - I'm working with our support/security folks to try to get 14.72.485.  We'll give that a go - and report back.


  • ApplePen's avatar
    Community Leader


    I have ever tried to use Chrome simulator to test by TestComplete.

    But it failed. The same problem that you mentioned.

    I thought that it was the limit in TestComplete.

    But as your description it can be done. Thanks for your information.

    It is very helpful for me.


    Maybe it is the problem in new version.

    I decide to update to 14.70.237 and try it again.

    I will report my result here later.


    By the way,

    My TC is

    Chrome is 88.0.4324.104.