Forum Discussion

abelsky's avatar
New Contributor
15 years ago

Stuck on "Loading Definition"

Hello Everyone;

I'd appreciate any pointers/advice if you have the time to reply.

I'm trying to add a WSDL from a secured web service to a new SoapUI project. SoapUI is stuck on the "Loading Definition" message, which won't go away until I hit the "Cancel" button.

SoapUI versions: 2.5.1, 3.0-beta2
Windows Vista Business

Steps I took to try to load the WSDL:
1. Created a new empty project (no WSDL reference)
2. Under Security Configurations -> Keystores/Certificates, I added the keystore with the signed certificate.
3. Right-clicked the project name, selected "Add WSDL", specified the HTTPS url to the WSDL (
4. Looking at the "Loading Definition" for 30 min, then cancel...

Wed Jul 08 09:44:46 EDT 2009:DEBUG:Getting wsdl component from []
Wed Jul 08 09:44:46 EDT 2009:DEBUG:HttpConnectionManager.getConnection:  config = HostConfiguration[host=], timeout = 0
Wed Jul 08 09:44:46 EDT 2009:DEBUG:Getting free connection, hostConfig=HostConfiguration[host=]
Wed Jul 08 09:44:46 EDT 2009:DEBUG:Freeing connection, hostConfig=HostConfiguration[host=]
Wed Jul 08 09:44:46 EDT 2009:DEBUG:Notifying no-one, there are no waiting threads

I also tried to set the Default Alias (and Alias Password) properties for the keystore, but it didn't solve the problem.

1. Loading non-secure WSDLs works just fine (where SSL wasn't involved).
2. I exported the certificate from the keystore, imported it into Firefox, and was able to access the hosted secured WSDL that I'm trying to load into SoapUI.
3. I saved the WSDL to a local file, imported it into SoapUI, and was able to run a request successfully.

If I remove the keystore, then I get SSL Handshake errors, so the keystore shouldn't be the problem. The certificate from the keystore also worked in Firefox...
If I execute "Update Definition" on the PortBinding, and replace the reference to the local WSDL with the reference to the hosted WSDL, then I get the same "Loading Definition" message that stays there until I hit the cancel button.

Does anyone know what I need to do to be able to import the hosted WSDL directly, and get past the "Loading Definition" message?


2 Replies

  • abelsky's avatar
    New Contributor
    Figured it out - I needed to add the server certificate (and its root certificate) as trusted to the JVM's cacerts keystore.
    Then I added my keystore in the following window: File -> Preferences -> SSL Settings

    Everything works like a charm. Hope this thread helps someone.
    • cata12's avatar

      I still get the "Loading Definition" message after adding the server certificate. Any specific steps you need to follow ? I see 2 certificates under my IIS server process.

      Also I don't https requests so I guess this will not solve my problem.