Forum Discussion

Bouyya's avatar
Bouyya
New Contributor
2 months ago

Soapui 5.7.1 dependency : thoughtworks:xstream:jar:1.4.20

Hello, 

I build my Soapui 5.7.1 with maven, in my pom.xlm I added the following dependencies:

<dependency>
                        <groupId>thoughtworks</groupId>
                        <artifactId>xstream</artifactId>
                        <version>1.4.20</version>

</dependency>

 But I still get the error "thoughtworks:xstream:jar:1.4.20: absent", (same thins with 'com.thoughtworks.xstream:xstream:jar:1.4.20' .

so I don't understand what is the difference is between 'thoughtworks:xstream:jar' and 'com.thoughtworks.xstream:xstream:jar', because soapui does not recognize 'com.thoughtworks.xstream:xstream:jar'. can you please help me, knowing that 'thoughtworks:xstream:jar;1.4.20' does not exist in https://www.soapui.org/repository/maven2

Thank you

2 Replies

  • Bouyya's avatar
    Bouyya
    New Contributor

    it does not work for me.

    my dependency :

    <dependency>
                            <groupId>com.thoughtworks.xstream</groupId>
                            <artifactId>xstream</artifactId>
                            <version>1.4.20</version>

    </dependency>

    the Error :

    Failed to execute goal com.smartbear.soapui:soapui-maven-plugin:5.7.1:test (Test__Test-soapui-project.xml) on project test: Execution Test__Test-soapui-project.xml of goal com.smartbear.soapui:soapui-maven-plugin:5.7.1:test failed: Plugin com.smartbear.soapui:soapui-maven-plugin:5.7.1 or one of its dependencies could not be resolved: The following artifacts could not be resolved: thoughtworks:xstream:jar:1.4.13 (absent): Could not transfer artifact thoughtworks:xstream:jar:1.4.13 from/to smartbear-sweden-plugin-repository (MirrorURL/www.soapui.org): status code: 403, reason phrase: -------------------->>> REQUESTED ITEM IS QUARANTINED -------------------->>> FOR DETAILS SEE ------>>><<<------ (403) -> [Help 1]

    I think he's searching for :

    thoughtworks:xstream:jar:1.4.13    not   com.thoughtworks.xstream:jar:1.4.13

    Thank you for your reply.