Forum Discussion

Arivazhagan-6's avatar
Frequent Visitor
4 years ago

Getting the following error ,while opening SoapUI 5.6

java.lang.UnsupportedClassVersionError: com/eviware/soapui/SoapUI has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
at com.exe4j.runtime.LauncherEngine.launch(
at com.install4j.runtime.launcher.UnixLauncher.main(


6 Replies

  • sippel's avatar
    Occasional Visitor
    Hi folks. Same problem occurs for me ... and it is not only for com/eviware/soapui/SoapUI, but for tools such as com/eviware/soapui/tools/JfxrtLocator, as well. System is Windows 10 with already installed jdk1.8 SopaUI 5.6 has been installed from May it be that SoapUI 5.6 has a problem with Java 8 and does not run on jdk1.8 anymore? Best reagrds.
    • nmrao's avatar
      Champion Level 3
      Which version of java are you using?
      • Islem's avatar
        New Contributor


        I have just made the BIG mistake of accepting to install the upgrade on Soap UI.
        My previous version was Soap UI 5.5.0 and I had Java 8.181 installed and everything was fine...

        Then, I still don't understand why, when I lauched my Soap UI, I've accepted to take the update...
        Then I got the exaclty same error message (printed herewith by the way) after the installation.
        Despite that Java is not anymore around version 52 or 53, but more like 7 or 8, I have understood that I needed to update also my Java Runtime.
        What I have done by installing the latest Java version --> 8.261
        Then, I still got the same error message...
        After, I was thinking that I may be need to restart my PC, what I've done full of hope (I must even say, last hope)...
        And guess what ?
        Still the same error message when I lauch Soap UI !

        That is why I'm here, can you please help me ?
        It is really urgent I must say.