Forum Discussion

speeddemon82101's avatar
13 years ago

Can't Apply Purchased license in Linux Environment

Hi I have done a SoapUI installation on a Linux server. I installed the soapUI pro 4.5 version at this following location on the linux server : /opt/soapui/

The process I follow to get to this soapUI installation is as follows:
1) I log into a workstation that is running Windows Server 2008 R2 Enterprise edition. So it is a server.
2) Then I run a XMing Session which allows me GUI access to the soapui installation
3) Then I use Putty to SSH into the liunx server where SoapUi is installed
4) I run this command ./ from the /opt/soapui/bin directory  This opens a GUI session of SoapUI via the Xming session

Where I am running into issues is getting the SoapUI install on the linux server to accept the license files above. It won’t accept either the key file and the subsequent activation files. I had copied these files into the soapui installation directory on the linux server using winscp

09:00:32,545 ERROR [SoapUI] An error occured [Unable to decode Launcher], see error log for details

From soapui-errors.log:

2012-05-17 09:00:32,545 ERROR [errorlog] Unable to decode Launcher Unable to decode Launcher
at com.eviware.soapui.SoapUIPro.b(SourceFile:510)
at com.eviware.soapui.SoapUIPro.validateLicense(SourceFile:749)
at com.eviware.soapui.SoapUIPro.checkLicense(SourceFile:325)
at com.eviware.soapui.SoapUIPro$
at com.eviware.soapui.SoapUIPro.main(SourceFile:276)

If you guys can provide an insight on this ASAP. It would be much appreciated.