Forum Discussion

sprice090161's avatar
5 years ago

Version 3.1 Deleted My Test Case Custom Properties

I didn't want to upgrade to the new look and feel of Ready API version 3.x just yet although I had installed v3.1.

I had previously been working in version 2.7 and I make extensive use of the Environments Console. 

I returned to Ready Api after a few months of manual testing helping out another team. I mistakenly logged into version 3.1. First thing I noticed was that I couldn't locate the Environments console, but then I figured out that they had integrated the configuration into the active page depending upon the user select environment server from the dropdown. At any rate I ran my groovy script that logs me into Azure and AWS and it failed complaining about a missing value in the body of the request that I provide called "client_id". I looked in my script and the client_id along with several other values are imported from the test case custom properties.


Here is my problem, all of the custom properties at the test case level are gone. I tried to go back and verify in v2.7 but the project got saved upon closing ready_api so I couldn't verify it. I think its the new integration that introduced a defect.


Has anyone else encountered this?

  • sprice090161,


    Upgrading ReadyAPI version shouldn't remove values of Test Case custom properties. Can you reproduce the issue with another project? If so, I recommend that you open a new support case here: and providing copies of your project before and after opening it in ReadyAPI 3.1.0. Also, provide the Support Team with the logs/errors if there are some. 

8 Replies

  • sprice090161 :


    I have also encountered this problem but with the Global Properties not with the Test Case Level Custom Properties when i moved from new version but i recovered that as i made all the custom properties configurable via groovy script.


    Don't know why it happened at Test Case Level Properties, have you got any chance to debug this?


    • sprice090161's avatar

      I tried recreating the same scenario in v2.7 for a different project but everything moved over fine when opened in v3,2. I may go back today and try again using the same project but I'm getting the feeling that this might be one of those first and only time things that happens to the project once you save it or open it under the new version. Those are weird bugs but do happen from time to time....just a guess on my part.

      • HimanshuTayal's avatar
        Community Hero

        sprice090161 :


        I would suggest you to open a support ticket for this issue via this link.


        This way your query will get resolved faster and with a appropriate solution like what's the matter that you are loosing your properties stored at certain level.


  • nmrao's avatar
    Champion Level 3
    May be you want to log an issue with Smartbear customer service.

    This wouldn't happen if the project is under repository such as git/SVN/cvs etc. It would be better to start using repository now.

    By the way you may check with your colleague or if the project is on different machine such as Jenkins if any.

    It always better to have a back up of the project if trying out new version of the tool.
    • sprice090161's avatar

      This isn't an issue pertaining to my use or non-use of GIT. This is an issue (potentially) caused by upgrading to a newer version and it makes sense since they eliminated the standalone environment console.