Forum Discussion

bnhuser's avatar
New Contributor
5 years ago

Unable to send certificate with Request - Keystore


I am unable to successfully send my requests with client certificates.

The exceptions I am getting are -

1. ERROR: org.apache.commons.ssl.ProbablyBadPasswordException: Probably bad JKS-Key password: Cannot recover key

2. ERROR: Uninitialized keystore


I have received a .crt and .key files (from third party), to be sent along with our requests


Postman - Able to successfully send requests with -crt and -key file.

Ready API - Failed.


Until now I have tried the following -

1. Converted the .crt-key files to ---> .p12 file (using OpenSSL) ---> .jks file (using Keytool).  No errors, successfully created .jks file

2. Cross - verified if the keystore file can be opened with the password (Yes - correct password) and if the Keystore contains a file within it (Yes)

3. Tried to set and use the keystore accordingly uising (Failed with above exceptions)


What am I missing here? Any input would be really appreciated.



3 Replies

  • Olga_T's avatar
    SmartBear Alumni (Retired)

    Hi bnhuser ,

    Thank you for reaching out!

    Do I get it right that you have contacted our Customer Care team with this question? I hope they help you find a solution as soon as possible. And, it would be great if you could share your progress here with the Community.


    In the meantime, Community, maybe has anyone faced a similar question? Does anyone have a ready solution?

    Thanks in advance!


    • bnhuser's avatar
      New Contributor


      Yes, I have created a new case for it.

      I still haven't found a solution for this. I'm unable to send the certificates in my requests.



      • Olga_T's avatar
        SmartBear Alumni (Retired)

        Thanks for the update, bnhuser !
        We will be waiting for your further results.