Forum Discussion

czimmer's avatar
New Contributor
10 years ago

Test runner license issue when running multiple tests simultaneously

Am running testRunner using bash scripts.

Want to run multiple tests to see how the system handles multiple users.


I run for i in {1..10};do echo $i;./ -t massmart -e brytrain02 -r $i -l1 -f 4 >> /home/ds/loadTest.txt 2>&1 & done


Am getting the following, which stops the process.

Since this is the first time you are running it after installing a new license,
you will need to accept the end user license agreement.
Please read it through carefully and review the conditions

View license agreement now? [y/N]: 12:57:35,312 INFO [WsdlProject] Loaded project from [file:/home/ds/projects/IntegrationTestClient/trunk/onceOffTestScripts/../testCases/IMPONE-813-CreateOrder-SimpleValida


I did see a previous post, but I not sure if it relates.


Is it possible to work around this, or is it a licencing issue. 

I have a valid licence for soapui, and checked that the .key file is in  /home/ds/.soapui/. The license works fine on the front end, and if I run the script one at a time i.e. ./ -t massmart -e brytrain02 -r $i -l1 -f 4




Claus Zimmermann

2 Replies

  • TanyaYatskovska's avatar
    SmartBear Alumni (Retired)

    Hi Claus,


    Keep in mind that the SoapUI license ties to the User and machine. Thus, if you are running TestRunner under a different user it will not be able to pick up the license. Could you please check if this is the case?

    If you still have an issue, I recommend that you contact our Support team ( ) – they will help you.


    • czimmer's avatar
      New Contributor

      Thank you Tanya.


      Yes, am using the same user on the machine.


      Will contact Support.