Forum Discussion

CHaefeli's avatar
New Contributor
10 years ago

SoapUI REST Mock Service with SSL


When I configure SSL support for Mock REST services and I try going to the HTTPS URL for a service that is working perfectly as normal HTTP I get the following html response:

<p>There are currently 1 running SoapUI MockServices</p>
<li><a href="/?WSDL">RESTTestMock</a></li>

The URL being called is:

There are a number of problems with this, firstly the href is clearly wrong it should point to the context path for the service but that could be my fault, however it also refers to a WSDL and not a WADL file and secondly I don't get the same response as if I go to the unsecured URL, e.g. this response:

"addresses": {
"address": [
"town": "Zurich"
"town": "Chiasso"
"id": 2,
"name": "Joe",
"surname": "Bloggs",
"testNamedProp": ""
"addresses": "",
"id": 1,
"name": "John",
"surname": "Doe",
"testNamedProp": {
"testkey": "testvalue"

The URL being called is:

I saw in the following post that someone else is having the same problem: viewtopic.php?f=13&t=25047

I have also tried deploying as a WAR to use tomcat which I have preconfigured for SSL however I don't get a war file, instead it puts an image, a stylesheet and a WEB-INF folder in the directory where I asked it to put the war file as though I had auto deployed, which I have not. If I deploy it directly to tomcat on the other hand I only get empty responses whatever I call.

If you could please give me some assistance with this it would be much appreciated.

7 Replies

  • SmartBear_Suppo's avatar
    SmartBear Alumni (Retired)

    The configuration applies to SOAP Mock Services. SSL is not currently supported for REST Mock Services. We have a feature request for that to be implemented in a future release (SOAP-2065).


    SmartBear Support
    • lotus_jp26's avatar
      New Contributor

      Hi there,


      I'm facing the same issue. Is this resolved in the latest version of SOAPUI5.2.1? 


      Thanks in advance,


      • alexs20's avatar
        New Member

        Nothing was changed since... Still doesn't work.