Forum Discussion

tamirav's avatar
tamirav
New Contributor
6 years ago

SOAPUI 2.3.0 - Problem with TestRunner

Hi,

 

I'm using ReadyAPI2.3.0, and I created my project/testsuite/test cases/test steps for REST services, bases on a swagger.

If I run my test steps one by one, they are executed successfully.
But when I select the test case and launch the test case runner, I receive '-1/error - failed' as result. And it seems it even didn't start to execute my test steps. I seems something is blocking on a higher level

 

The project also doesn't run when executed by someone else in their SOAPUI. So it seems the project is corrupted?

So I restarted a new project and started from scratch - just with one basic service, but I still have the same problem.

 

I'm out of ideas what I can do to fix this problem  ...

 

In annex you'll find the error message/warning I received.

And I also included the project, just in case ....

 

PS.During startup program - I receive following error in the Ready API log

"INFO:Not able to download updates JSON file from URL http://productextensions.s3.amazonaws.com/dashboard/dashboard-updates.json - error: {}"

 

Thanks for your feedback,

Kindest regards,
Tamira

2 Replies

  • why are all of your steps disabled? If you run the test from the testcase or testsuite level the only step that will run will be POST Request_Fix. With that being said when you run from TestRunner it will execute just that one step.

    • tamirav's avatar
      tamirav
      New Contributor

      If it can't run 1 test, it can't run many tests.

      So I disabled the others for trail/error purpose ... just until the run on test case/suite level works.

      I can enable all the tests, it has the same result, nothing happens.

      I my experience I always try with a small subset to validate it works, and when it works release the full blown.