Forum Discussion

ankushsingh712's avatar
ankushsingh712
New Contributor
11 years ago

Report generated is not in single page HTML file fromat

Hello All,
I am new to SoapUI, currently i have once test cases created in soapUI now i run it from command line on windows 7 machine, for report i opted HTML format but the report is being generated is not in single page HTML report. actually it is generated in HTML with webfolder.
command is as follows:
testrunner.bat -s"SANITY TEST SUITE" -j -fC:\Users\username\Desktop\Projectfolder\projectname\Reports -R"Sanity Report" -F "Single Page (Print)"-EDefault C:\Users\username\Desktop\Projectfolder\projectname\REST_API\application-987-soapui-project.xml

9 Replies

  • nmrao's avatar
    nmrao
    Champion Level 3
    Do you see index.html which is the main page. Or do you see any issue which is not clear from the post?
  • hello nmrao,
    thanks for the reply, yes i can see the index.html, i want to create report in the way it is created using create report wizard in SoapUI tool.
    Create Report wizard-> Format: "Junit-Style HTML Report" ->Options Style:"Single Page(Print)". if create in this way it is created with only Single HTML file , i also want to create report in same format while running test from command prompt.
  • I have having the same issue. PDF Report is not generated when I run the following command on unix:

    /opt/SmartBear/soapUI-Pro-4.5.2/bin/testrunner.sh -s"MyTestsuite_TestSuite" -a -f/tmp/Reports -R"TestSuite Report" -FPDF -Dsoapui.home=/opt/SmartBear/soapUI-Pro-4.5.2 /tmp/test_project.xml

    However if I specify -FCSV, the txt files are generated in the report folder.
    I have wasted a lot of time trying to generate this pdf report on the unix machine. Please can someone help me.
    Thanks a lot in advance.
  • @ Rao: Thanks.

    But, unfortunately it did not work. Basically, I ran the similar command on my windows machine after changing the path to the installable and the report directory:
    <code> C:/SmartBear/soapUI-Pro-4.5.2/bin/testrunner.bat -FPDF -R'Project Report' -fC:/Reports1 -Genv=QA soapui_project.xml
    </code>
    It shows the following soap ui logs at the end.
    [SoapUIProTestCaseRunner] Created report [Project Report] to path [C:\Reports1\Project Report.pdf]

    However, when I run the same on unix(after changing path to installable and report directory), the above logs do not appear.Can anyone please help me? It has been a long time since I got this issue. Should I get soap ui pro re-installed on the unix machine?
  • nmrao's avatar
    nmrao
    Champion Level 3
    just provided spacing between the options and quotes, please see if this helps
    $SOAPUI_HOME/bin/testrunner.sh -FPDF -R "Project Report" -f "/tmp/Reports1" -G env="QA" soapui_project.xml
  • @Rao: Thanks

    I have changed the value in testrunner.sh to"-Dsoapui.home=$SOAPUI_HOME/bin instead of -Dsoapui.home=$SOAPUI_HOME". Now soap ui is trying to generate the report. However, it is now throwing error related to font.
    net.sf.jasperreports.engine.util.JRFontNotFoundException: Font 'Arial' is not available to the JVM. See the Javadoc for more details.
    at net.sf.jasperreports.engine.util.JRFontUtil.checkAwtFont(JRFontUtil.java:358)

    However, I wanted to know if it is possible to run the report or confirgure the report in soap ui pro to a font which is already existing in system?
    Thanks & Regards,