Forum Discussion

rajeshvr's avatar
rajeshvr
New Contributor
2 years ago

HttpHostConnectException is returned even though switched the proxy settings as Automatic to none

HttpHostConnectException is returned even though switched the proxy settings as Automatic to none and none to automatic. since there is no firewall issue, but still I am getting the following error : org.apache.http.conn.HttpHostConnectException: Connect to www.XXXXX.com:443 [www.XXXXX] failed: Connection timed out: connect. 

I can able to launch the UI without any issues.

Facing this problem on ReadyAPI 3.10.2 version

6 Replies

  • richie's avatar
    richie
    Community Hero
    Hey rajeshvr,

    The error youre getting is pretty fundamental. This isnt an issue of payload or payload creds, its something a lot more basic than that......like proxy settings or http rather than https (or the reverse) or SSL/TLS settings or simply the completely wrong endpoint.

    Youll need to go back to your requirements to confirm the details. One of the above mentioned settings is incorrect, but id guess we wont be able to provide better answers for this as this isnt a ReadyAPI "issue"....your basic settings are incorrect somewhere and youll only be able to identify these by confirming the technical requirement and then matching those in ReadyAPI.

    Cheers,

    Rich
  • rajeshvr's avatar
    rajeshvr
    New Contributor

    I have verified the proxy settings, http/ https, SSL/TLS settings and endpoint. Still I am facing same issues. I had mimic the same configurations as done by my colleague (as working in their machine) but still not resolved. I can able launch the end point directly so there is no firewall issues with my machine.

    • richie's avatar
      richie
      Community Hero

      Hey rajeshvr 

       

      if your colleague has already setup a working project, rather than try and mimic his setup, why not at import your colleagues project and see if it runs within your ReadyAPI instance? 

       

      If it doesn't then the issue will be config external to ReadyAPI - 'hosts' file entries, firewall config, etc., etc.  

       

      Cheers,

       

      Rich

      • richie's avatar
        richie
        Community Hero

        TanyaYatskovska sonya_m 

         

        I mistakenly hit the 'Accept as Solution' button (cos after you hit 'Reply' - the 'Reply' button disappears and the 'Accept as Solution' button moves into it's place! :() - would you mind undoing this change please?  The issue hasn't been resolved yet.

         

        Thanks,

         

        Rich

  • sonya_m's avatar
    sonya_m
    SmartBear Alumni (Retired)

    Hi richie! I removed the solution as you asked. You have permissions to do this too, simply click post options and there will be the 'Not the Solution' option.

    • richie's avatar
      richie
      Community Hero
      Hey sonya_m,

      I did wonder if i had the privileges to do this and did have a quick look around.....obviously i didnt look hard enough!😉

      Cheers!