Forum Discussion

Sehuang's avatar
Occasional Contributor
6 years ago

Error while running ReadyAPI 2.4.0 Linux tarball package

Steps I have run:

1. my server is SUN solaris

2. transferred ReadyAPI-2.4.0-linux-bin.tar.gz to the server.

3. unzip the package 

4. checked that the java environment is jdk1.8

5. run ->     ./ <my soapui project.xml>

6. received error: Could not initialize class  and also Problem reading font data.



1. does ReadyAPI-2.4.0-linux-bin.tar.gz support SUN solaris?

2. if yes, I suppose it is the package for headless machine so why do I need UISupport class? 


please find attached the log

10 Replies

  • jhanzeb1's avatar
    Frequent Contributor



    Apologies if I have misunderstood your question. 


    Here is a list of OS supported by ReadyAPI:


    • Windows 7 SP1 with convenience rollup update (KB3125574) or a later Windows operating system (32- or 64-bit).

    • Windows Server 2008 R2 SP1 with convenience rollup update (KB3125574) or a later Windows Server operating system.

    • OS X 10.7.3 (Lion) or a later macOS operating system.

    • OS X Server 10.7 (Lion) or a later macOS Server operating system.

    • 64-bit Oracle Linux 6 or later.

    • 64-bit Red Hat Enterprise Linux 6 or later.

    • 64-bit Suse Linux Enterprise Server 10 SP2 or later.

    • Ubuntu Linux 10.04 or later.

    Although it does not mention Solaris explicitly, it is still a unix OS, so not 100% sure if it will work. 

    UISupport class should not be there if the package is for a headless machine. Can you double-check if it's the correct package being installed?  


    Some debugging questions: 

    1. Is the file ( you are trying to execute correct? 

    2. did you make this file executable? i.e chmod +x ./file_name? 


    Still not sure of your context. Could you explain more? i.e what is it you are trying to achieve? Is this task being achieved on a headless machine? What Solaris version is it? etc..  

    • Sehuang's avatar
      Occasional Contributor
      I try to run ready API 2.4.0 in headless machine (Solaris version to be confirmed). As there's no connection from the machine to internet, I downloaded the Linux tarball package manually, transfer to this machine and unzip it.
      • jhanzeb1's avatar
        Frequent Contributor

        Are you just trying to install ReadyAPI on a headless machine? if so, then you should be running this file?   ./ -c

  • Sehuang's avatar
    Occasional Contributor
    Hi jhanzeb1,
    Thanks for your reply. Below is the link I used to download. It's Linux tarball as per the website.

    Once I downloaded it, I ran gzip -d and tar to unzip the package. My server has jdk1.8 already so after unzip I ran ./ under Readyapi2.4.0/bin/ with my project XML. The is executable. As you said, headless should not require Uisupport class. But when I run it, it complaint about unable to initiate the Uisupport class. So is there anything I need to do in the file to disable initiation of the Uisupport class or anywhere else I need to change? Another error is problem finding the font.