Forum Discussion

wwilbur's avatar
Occasional Contributor
3 years ago

ERROR: org.postgresql.util.PSQLException: FATAL: too many connections

I have closed all connections to the Postgresql database, closed all apps connecting to it, rebooted my computer and still get the above message. This has happened many times for the Postgresql databases. Is there a way to fix. I do not have admin to increase connections so need to find a way to make sure all connections are closed before starting script


  • I went ahead and used another Postgresql database that does not contain PCI information. It worked


    Bill Wilbur
    Quality Assurance Analyst
    Information Technology
    O'Reilly Auto Parts
    (417) 862-2674 ext. 1603

    The information transmitted is intended only for the person or entity to which it is addressed and may contain proprietary, business-confidential and/or privileged material. If you are not the intended recipient of this message you are hereby notified that any use, review, retransmission, dissemination, distribution, reproduction or any action taken in reliance upon this message is prohibited. If you received this in error, please contact the sender and delete the material from any computer.

5 Replies

    • wwilbur's avatar
      Occasional Contributor

      I tried this but it did not work, thank you for replying

      • richie's avatar
        Community Hero
        Hey wwilbur,

        The info on the stackoverflow page (the query) should work as the table holds a list of all the connections. Can you clarify exactly what you did and what occurred when you tried? Cos killing that pid works.

        Ive re-read your description again and im guessing that keeping active connections in the pool is an issue with postgresql, so theres not much you can do from the other end of things (ReadyAPI) to resolve. This is NOT an issue with ReadyAPI, so the resolution at best is gonna be running a query or a kill command in the OS or something similar. This issue would occur whatever application was hitting the database. Thats where you need to resolve the issue, im thinking