Forum Discussion

chanthj's avatar
chanthj
New Contributor
10 years ago

Error getting response; java.lang.StackOverflowError

I have been using SoapUI 4.6.4 for a couple of years. All the sudden it got an error "Error getting response; java.lang.Exeption: java.lang.StackOverflowError" when I run my soap request. This error appears at the bottom of the screen. The error log did not give me any good clue. Below are a couple of lines from the error log.
at sun.org.mozilla.javascript.internal.CodeGenerator.visitExpression(Unknown Source)
at com.eviware.soapui.impl.wsdl.submit.transports.http.HttpClientRequestTransport.sendRequest(HttpClientRequestTransport.java:232)

I installed SopaUI 5.0.0 to run my soap request. I still have the same issue. So this tells me that it is not a SoapUI issue but java issue. However I don't know exactly what is the root cause yet. If anyone had the same issue and solution I would really appreciate it, if you can share. In the mean time I will keep on researching.

6 Replies

  • chanthj's avatar
    chanthj
    New Contributor
    OK, I found the solution. JVM was running out of memory. I had to set the stack memory size to 512m. To do so, go to C:\Program Files (x86)\SmartBear\SoapUI-4.6.4\bin. Edit soapui.bat file to have JAVA_OPTS line looks like mine below. Restart the SoapUI. I got no more StackOverflowerror. Woo took me a while to figure out but I am glad I did.
    set JAVA_OPTS=-xms512m -Xms256m -Xmx2048m -Dsoapui.properties=soapui.properties "-Dsoapui.home=%SOAPUI_HOME%\" -splash:soapui-splash.png
    • Remy_Fale's avatar
      Remy_Fale
      Occasional Contributor

      Hello mates,

      I have changed my JAVA_OPT in SOAPUi5.4.0/bin and my looks like below:

      set JAVA_OPTS=-xms512m -Xms256m -Xmx2048m -XX:MinHeapFreeRatio=20 -XX:MaxHeapFreeRatio=40 -Dsoapui.properties=soapui.properties "-Dsoapui.home=%SOAPUI_HOME%\" -splash:SoapUI-Spashscreen.png

       

      But it still not working - Something wrong?

      help..

       

      Remy

      • groovyguy's avatar
        groovyguy
        Community Hero

        Remy_Fale: You are replying to a thread that is 4 years old. You may want to consider starting a new post and giving your specific details. Thanks!

  • chanthj's avatar
    chanthj
    New Contributor
    Here is more information that I did to troubleshoot. I increased the java run time memory and still have the same issue. I downloaded SoapUI Pro version 5.1.2. It is working fine for me. So this rules out java issue. Other developer in my team do not have any issue with their SoapUI 4.6.4. I still need to solve this issue.