Forum Discussion

huurm900's avatar
huurm900
Occasional Contributor
7 years ago
Solved

[CompositeProjects] The file has not been loaded, because the project does not contain it:

When I run Ready API from GIT I worked on 2.3

 

now i run it with 2.4 and i does not find the project file anymore. How can I make it find it again?

 

 

HEAD is now at 1eeb9d4 Update .gitlab-ci.yml
Checking out 1eeb9d4f as master...
Skipping Git submodules setup
$ /opt/readyapi/bin/testrunner.sh $CI_PROJECT_DIR -f$CI_PROJECT_DIR/TestResult -I "-ETST1" "-RJUnit-Style HTML Report"
================================
=
= READY_API_HOME = /opt/readyapi
=
================================
- No base packages specified - no classpath scanning will be done
- Starting 'LifecycleManager@632071960'
- Hibernate Validator 4.1.0.Final
- Adding module 'com.smartbear.ready.cmd.CommandLineModule
08:42:13,490 INFO [license] ReadyAPI 2.4.0 (build 814) started - System properties: {OS=Linux, User name=gitlab-runner}
08:42:13,493 INFO [DefaultSoapUICore] Creating new settings at [/home/gitlab-runner/soapui-settings.xml]
08:42:13,785 INFO [SoapUIExtensionClassLoader] "/opt/readyapi/bin/ext/ojdbc7.jar" has been added to the classpath.
08:42:13,879 INFO [DefaultSoapUICore] 1 JDBC drivers have been registered from the directory bin/ext: [oracle.jdbc.OracleDriver].
08:42:14,049 WARN [SoapUIProGroovyScriptEngineFactory] Missing scripts folder [/home/gitlab-runner/builds/2aef3656/0/PensionsAndRetail/BeFrank-Final-Regression/scripts]
08:42:14,050 INFO [DefaultSoapUICore] Adding listeners from [/opt/readyapi/bin/listeners/demo-listeners.xml]
08:42:14,119 WARN [SoapUIJasperReportManager] The path to the report directory has been set to the default value because the report format has changed. Please update your custom reports if you want to use them with ReadyAPI 2+.
08:42:15,392 INFO [PluginManager] 0 plugins loaded in 17 ms
08:42:15,392 INFO [DefaultSoapUICore] All plugins loaded
08:42:15,504 WARN [SoapUIProGroovyScriptEngineFactory] Missing scripts folder [/home/gitlab-runner/builds/2aef3656/0/PensionsAndRetail/BeFrank-Final-Regression/scripts]
08:42:15,968 DEBUG [LicenseManagerServiceImpl] Trying to initialize license for SoapUI
08:42:15,971 DEBUG [LicenseManagerServiceImpl] No license found for SoapUI
08:42:15,978 DEBUG [LicenseManagerServiceImpl] Trying to initialize license for SoapUI
08:42:15,979 DEBUG [LicenseManagerServiceImpl] License host for SoapUI: SRPADAPP4011.MGT.INSIM.BIZ
08:42:15,988 DEBUG [LicenseManagerServiceImpl] License host for SoapUI: SRPADAPP4011.MGT.INSIM.BIZ
08:42:16,007 DEBUG [LicenseManagerServiceImpl] Valid license file found: /home/gitlab-runner/.soapui/soapui.key, last modified: Wed Apr 11 15:04:06 CEST 2018
08:42:16,161 DEBUG [LicenseManagerServiceImpl] Trying to initialize license for LoadUI
08:42:16,161 DEBUG [LicenseManagerServiceImpl] No license found for LoadUI
08:42:16,170 DEBUG [LicenseManagerServiceImpl] Trying to initialize license for Secure
08:42:16,171 DEBUG [LicenseManagerServiceImpl] License host for LoadUI: SRPADAPP4011.MGT.INSIM.BIZ
08:42:16,179 DEBUG [LicenseManagerServiceImpl] No license found for Secure
08:42:16,185 DEBUG [LicenseManagerServiceImpl] Trying to initialize license for ServiceV
08:42:16,193 DEBUG [LicenseManagerServiceImpl] License host for Secure: SRPADAPP4011.MGT.INSIM.BIZ
08:42:16,194 DEBUG [LicenseManagerServiceImpl] No license found for ServiceV
08:42:16,207 DEBUG [LicenseManagerServiceImpl] License host for ServiceV: SRPADAPP4011.MGT.INSIM.BIZ
08:42:16,247 WARN [CompositeProjects] The file has not been loaded, because the project does not contain it: /home/gitlab-runner/builds/2aef3656/0/PensionsAndRetail/BeFrank-Final-Regression/holdercommandservice/%2Fholder%2F%7BholderId%7D.xml
08:42:16,247 WARN [CompositeProjects] The file has not been loaded, because the project does not contain it: /home/gitlab-runner/builds/2aef3656/0/PensionsAndRetail/BeFrank-Final-Regression/holdercommandservice/%2Fholder.xml

  • NBorovykh's avatar
    NBorovykh
    6 years ago

    Hi maged_ahmed,

     

    Thank you for sharing the w/a with the Community! The described issue is the known one in 2.4.0. It's fixed in the maintanence build of version 2.4.0 and in version 2.5.0. 

12 Replies