Forum Discussion

Kostja's avatar
Kostja
Contributor
8 years ago
Solved

Three questions about QAComplete from a beginner

Hey guys,   we recently purchased the Enterprise version of QAComplete. Now there are two questions i would like to ask.   These are:   1. When starting a test run there is always a 3-5 minutes...
  • CGangloff's avatar
    8 years ago

    Hello Konstantin, thank you for your post. Regarding your questions:

     

    1) It can take up to 15 minutes to actually start an automated test. It is related to the peculiarities of the Test Agent functioning. It takes time for the Test Agent service to send a request to the QAC web service and check whether there is a job (a test to be run) for the target host. Plus, on the QAC server side, the corresponding job manager service is not running all the time, it starts periodically (by default, every 5 minutes) and checks for actual jobs. In addition to this, it actually takes time to start the automated testing tool (TC/TE in your case) on the test host.

     

    The time period to check jobs to run can be set on the server side via the Service Manager Configuration utility (by default, it is located here: "C:\Program Files (x86)\SmartBear\ServiceManager\Config.exe"). However, 5 minutes is the minimal period which you can set.

     

    2) This behavior can occur when not using US Regional settings for the Web and SQL server. Please try following the below steps to get rid of this issue:

    * Configure the Server machine to use the US regional setting for its date format:
    * Run the Registry Editor tool (regedit).
    * Drill down to the "HKEY_USERS\S-1-5-18\Control Panel\International" hive and locate the sShortDate option.
    * The entry value for "sShortDate" should be "M/d/yyyy". You can switch between the "M/d/yyyy" and "MM/dd/yyyy" date formats to see which one works better.

     

    * Copy this setting over to the default user account and the local system accounts. For that, follow these steps:
    * Open Control Panel, switch the view to "Small icons" and select "Region".
    * Make sure that Format is set to 'English (United States)'.
    * Switch to the Administrative tab, and click "Copy settings".
    * In the pop-up screen, check the 'Welcome screen and systems accounts" option and click OK.

     

    If this does not help, please contact QAComplete support at: https://support.smartbear.com/message/?prod=ALMComplete and send us screenshots demonstrating the problem.

     

    3) Konstantin, do we understand correctly that you are starting TC tests from QAComplete? What kind of failures do you get on the problematic VMs?

     

    If the problems you face are actually some issues with starting TestComplete/TestExecute on the particular test hosts, then these issues can be related to QAComplete-TestComplete integration indeed. But in case you are talking about test execution errors which appear during the TC test execution (present in the TC test execution log), then the issue is on the test design side, and it is actually about TestComplete, not QAComplete or Test Agent.

     

    Please describe the situation in more detail by contacting QAComplete support at: https://support.smartbear.com/message/?prod=ALMComplete

     

    Thank you,
    Christiane