Forum Discussion

arunbharath-bfg's avatar
arunbharath-bfg
New Member
3 months ago

Bitbar Run-in-Cloud Plugin not working

I have a CICD where I need to test native app. I'm running Appium server side test, to integrate with plugin as mentioned in the document I have used Run-in-Cloud plugin syntax, but Unfortunately, I'm getting Framework requires test file with extension: apk eventhough I have uploaded apk file

Below is my runInCloud script

runInCloud(

cloudUrl: "https://cloud.bitbar.com",

credentialsId: "bitbar-api-key",

projectId: "207321147",

deviceGroupId: "14",

appPath: "universal_qa.apk",

testPath: "test-package_android.zip",

frameworkId: 252,

biometricInstrumentation: false,

 

// Wait for results!

waitForResultsBlock:

[

downloadScreenshots: true,

resultsPath: 'results',

testRunStateCheckMethod: 'API_CALL'

]

)

Above is my script, After jenkins run, I can see respective apk and zip files are uploaded into the bitbar (verified manually). but It is not running the test case. below is my jenkins log



17:17:38 WARNING: Unknown parameter(s) found for class type 'com.testdroid.****.PipelineCloudStep': waitForResults
17:17:38 Run test in Bitbar Cloud process started...
17:17:38 Using login details from the credentials manager, which overrides basic username/password specified in settings.
17:17:39 Uploading new application file universal_dev.apk
17:17:44 Uploading new instrumentation file test-package_android.zip
17:17:45 Waiting for uploaded files to be scanned
17:18:19 Running tests
17:18:19 Using test run configuration:
17:18:19 Bitbar Cloud URL: https://cloud.bitbar.com Version: 3.25-master-20231129-151806
17:18:19 Using credentials with ID: bitbar-api-key
17:18:19 Device Group Name: Trial Android devices ID: 14
17:18:19 OsType: ANDROID
17:18:19 Framework ID: 252
17:18:19 Locale: en_US
17:18:19 Scheduler: PARALLEL
17:18:19 Timeout: 1800
17:18:19 Problem with the Bitbar API. Please check credentials or contact support@bitbar.com: Framework requires test file with extension: apk

I don't know why I'm getting above error, eventhough there is an .apk file. Any help would be great, stuck here for couple of days

 

1 Reply

  • We are getting the same error when trying to run "Android Instrumentation and Espresso" both when trying via the API (and python script) and when trying via the UI at https://cloud.bitbar.com.

    We're using APK-files we've previously used for other test-frameworks without any issues.