Forum Discussion

Hardik_Gahoi's avatar
Occasional Visitor
4 years ago

Getting invalid credentials when configuring Zephyr Scale with Jenkins



I am doing a POC for Zephyr Scale on cloud. One of the feature we want to explore is integrating it with Jenkins to publish robot results.


I installed Zephyr scale plugin in Jenkins. When i am trying to configure Jenkins scale i am getting Invalid Credentials error. I tried generating several API keys but got same error all the time.


Please let me know if anyone has any solution.


5 Replies

  • MrP's avatar
    Occasional Contributor

    Encountering this as well.  In my case, I have both Jenkins and Jira running in Docker containers FWIW.

    • MrP's avatar
      Occasional Contributor

      Resolved my issue. Turns out that Zephyr Scale had not been properly activated for a Project.  Setting up Jira in Docker, the initial admin account was a Jira Administrator.  I had to enable Jira System Administrator permissions in Settings > Global Permissions to my account.  Once I did that, I was able to activate Zephyr Scale for my Project, and was no longer getting the invalid credentials error in the Jenkins configuration pane for Zephyr Scale.

  • jfelix's avatar
    SmartBear Alumni (Retired)

    Hi, Hardik_Gahoi! Thank you for your question.


    Could you please try MrP's steps and check if Zephyr Scale is enabled on your project? Since you're using the cloud version, you won't see the Global Permission option in Jira settings, but you'll see whether the project is enabled by selecting it and then going to Zephyr Scale or by opening the project settings and click on the Zephyr Scale menu in the sidebar.



    • sealdog's avatar


      Getting the same thing, in the Zephyr Scale plugin for Jenkins, trying to add a Jira instance.


      I'm running Jira v8.13.4 on prem with a new user on the jira local directory. The user is an administrator. This is in Jenkins setup before you even specify a project, so it's likely not a project thing.


      The error message is not helpful "Invalid credentials." I've double checked the username and password.


      BTW, I am evaluating Zephyr Scale for approximately 1000 user license purchase. Please help.


      • zephyrvinay's avatar
        Regular Visitor

        jfelix ,did you get a solution to posted query, as I am also facing the same. User account has super administrator permission and Zephyr scale is enabled at project level.i am using sever based jira instance to connect