Forum Discussion

lvega01's avatar
lvega01
Occasional Visitor
6 months ago

401 Authorization Error/Timeout

Hi,

I am currently working with codebase in ruby which exports XRay data from Jira with the intention of importing the data as testcase in Zephyr. The Zephyr server is up an running. I have the API token with the credentials as well. I believe is able to reach Zephyr through the token since the API token website reflect being accessed in the indicated time I run the codebase. The import function is as follows:

def import_test_exports_into_zephyr(xray_project_id, zephyr_project_id, release_id)
temp_test_folder_id = 17
tasks = []
test_exports = get_test_export_objects(xray_project_id)
test_exports.each do |test_export|
task = lambda {
return Zephyr::create_test(test_export, zephyr_project_id, release_id, temp_test_folder_id)
}
tasks << task
end

responses = Async::run_tasks(tasks)

responses.each do |response|
puts response
end
end

 

The purpose of the function is to create multiple test cases and import them in async manner. There are two types of error that I am getting when I run the codebase:

Sometimes is this one:

Failed to open TCP connection to BASEURL:443 (Blocking operation timed out!) (IO::TimeoutError)

Other times is this one:

{
  "errorMsg" : "You do not have WRITE permission to perform this operation. Please contact the administrator.",
  "errorCode" : "102z01"
}

any suggestions?

Thank you,

Luis

No RepliesBe the first to reply