Forum Discussion

rajulapati's avatar
rajulapati
Contributor
4 years ago
Solved

Which version of POI bin files are compatible with SOAP UI 5.5 free version

I am having Soap UI 5.5 version and trying to read an xlsx file. Previoulsy I had 4.6.4 and had no issues with the script.

now after upgrading to 5.5 version I am seeing error  "unable to resolve org.apache.poi.xssf.usermodel.XSSFSheet".

 

I have tried using poi bin files with version 4..1.2 , 4.1.1, 4.0.0 & 3.8 but still I am getting an error "unable to resolve org.apache.poi.xssf.usermodel.XSSFSheet"

 

Every time I use the new version of bin files made sure poi-ooxml .jar file is there and I re-open SoapUi to run the groovy script.

 I have copied belwo jar files  in to SoapUI/bin/ext

commons-collections .jar

poi-4.1.2.jar

poi-contrib-4.1.2.jar

poi-examples-4.1.2.jar

poi-excelant-4.1.2.jar

poi-ooxml-4.1.2.jar

poi-ooxml-schemas-4.1.2.jar

poi-scratchpad-4.1.2.jar

 

Any suggestions would help

  • rajulapati's avatar
    rajulapati
    4 years ago

    There were two versions of Soap UI installed which actually casued the issue, after installing the lower version the issue is fixed.

8 Replies

  • nmrao's avatar
    nmrao
    Champion Level 3
    Have you restarted after copying files.
    • rajulapati's avatar
      rajulapati
      Contributor

      Yes I have restarted after Copying fiels, still getting the same error

      • nmrao's avatar
        nmrao
        Champion Level 3
        Ok. Do you know which jar file has this class?