Forum Discussion

kkr's avatar
New Contributor
7 years ago

SOAPUI shows ClassnotFound Error when running a groovy script



I am using jxl jar to create an excel file and I have copied the jar file to SOAPUI/lib folder. But when I run the groovy script in SOAPUI 5.4.0 it is throwing the below error.


org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: Script2.groovy: 41: unable to resolve class WritableWorkbook @ line 41, column 29.


I have added all import statements in the code and also tried classpathhacker option as well, but no luck. I have verified the java.class.path values in SOAPUI system properties and I see that jxl jar added to classpath. But when I run the groovy script it is showing the above error. This is happening on my citrix windows machine. But the same code and steps works on my other non citrix windows machine. Please let me know what are options we need to check to load third party jar in the citrix windows SOAPUI classpath.

I am using SOAPUI free version.




No RepliesBe the first to reply