Forum Discussion

Cowdudesanta's avatar
Cowdudesanta
New Contributor
8 years ago

SoapUI Crashing

Computer Specs:

Win 7 Pro x64

8GB memory

 

SoapUI version 5.3.0 w/out built in browser

Java version 8.121

 

Whenever I start SoapUI the splash screen will come up and then load SoapUI. It'll give me the prompt asking if I want to "Stay in the Loop" .. I click skip and then a few seconds later the app crashes. The crash "Java Platform SE binary has stopped working" comes up and I close out of the app. I've checked to make sure this wasn't memory related. I don't seem to be running out of memory. I make sure no other apps are running when I've been trying to get this to work.

 

When I run the soapui.bat I get the message saying JAVA_HOME is not set. Can someone tell me where in the code I need to set this? I've attached a snippet of the soapui.bat. I'm not a developer/programmer. I'm trying to help someone within our company.

 

I've also tried installing 5.3.0 with the built in browser and the same thing happens. It'll open and then crash.

 

I'd really appreciate any help. I've been beating my head against this for days.

 

 

2 Replies

  • This is the error log I get when using 5.3.0 with built in java browser:

     

     

     2017-03-07 15:15:15,441 ERROR [errorlog] java.lang.ClassNotFoundException: com.eviware.soapui.plugins.auto.factories.AutoDiscoveryMethodFactory
    java.lang.ClassNotFoundException: com.eviware.soapui.plugins.auto.factories.AutoDiscoveryMethodFactory
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at com.eviware.soapui.plugins.LoaderBase.loadAutoFactories(LoaderBase.java:112)
        at com.eviware.soapui.plugins.LoaderBase.loadFactories(LoaderBase.java:80)
        at com.eviware.soapui.plugins.PluginLoader.loadPluginFactories(PluginLoader.java:141)
        at com.eviware.soapui.plugins.PluginLoader.loadPlugin(PluginLoader.java:104)
        at com.eviware.soapui.plugins.PluginLoader.loadPlugin(PluginLoader.java:54)
        at com.eviware.soapui.plugins.PluginManager.doInstallPlugin(PluginManager.java:141)
        at com.eviware.soapui.plugins.PluginManager.access$600(PluginManager.java:43)
        at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.computeSequentially(PluginManager.java:420)
        at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:377)
        at com.eviware.soapui.plugins.PluginManager$LoadPluginsTask.compute(PluginManager.java:365)
        at java.util.concurrent.RecursiveTask.exec(Unknown Source)
        at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
        at java.util.concurrent.ForkJoinWorkerThread.execTask(Unknown Source)
        at java.util.concurrent.ForkJoinPool.scan(Unknown Source)
        at java.util.concurrent.ForkJoinPool.work(Unknown Source)
        at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)

  • JAVA_HOME has been set in my system enviroment variable as my install path for JRE 1.8.121 but when I run the soapui .bat it still shows it using the built in browser. How do I disable this built in browser? Attached shows my java home set.