Forum Discussion

pyrinoff's avatar
New Contributor
5 years ago

Problem with encoding

Hi there!

I have a problem with system encoding:


And I cant change this option on working computer (file is not accessable to write):


The problem:

1) (screen 1) I cant change encoding in REST mock. I tried simply show HTML page, but it is in wrong encoding (cp1251)

2) (screen 2) I get response from mock, and then send it to another service. Result: my request sended in cp1251, not in utf-8, even if i set Encoding = UTF-8 to request settings


Any suggestions how to fix it without Dfile.encoding=UTF8.
I'm not a java-guy, tryed something like

 new String(context.expand( '${Redirect to local mock#Response}' ).getBytes('UTF-8'), 'UTF-8')

but no luck.


Thanks a lot!


3 Replies

  • nmrao's avatar
    Champion Level 3
    As this is part of the work request your administrator to allow you with the required change to the file or request them to make the change. I don't think that the request will be denied.
    • pyrinoff's avatar
      New Contributor

      Maybe exists some groovy way to change/convert encoding of stiring ...
      Or some way to pass option as startup parameter for shortcut.


      System admins response in weeks, and the project from SOAP will used by many users, but not so important to wait for few weeks, so that's not comfortable and quick way.

      UPD:  tried setProperty("file.encoding", 'UTF-8') + set encoding to utf-8 everywhere, but no luck

      Check out the project i attached (it may required to set file.encoding to cp1251 manually in options to simulate issue)

      • nmrao's avatar
        Champion Level 3
        Got utf-8 as file encoding.
        Can see correct in raw response and response edit doesn't show correctly.

        Thank you for the share.