Forum Discussion

plsnrk's avatar
plsnrk
Visitor
2 years ago

OpenAPI v3.0.1 support in SoapUI open source?

Hi,

I'm using SoapUI 5.7.0 (open source) and try to import an openAPI 3.0.1 spec (JSON).

 

When using Project > Import Swagger/OpenAPI definition, it fails with a NullPointerException :

 

  • Tue Nov 08 09:28:55 CET 2022:ERROR:java.lang.NullPointerException
  • java.lang.NullPointerException
  • at com.smartbear.swagger.SwaggerUtils$1.construct(SwaggerUtils.java:143)
  • at com.eviware.soapui.support.swing.SwingWorkerDelegator.construct(SwingWorkerDelegator.java:46)
  • at com.eviware.soapui.support.swing.SwingWorker$2.run(SwingWorker.java:131)
  • at java.base/java.lang.Thread.run(Thread.java:834)

My question : is SoapUI openSource 5.7.0 able to import v3(.0.1) openAPI definitions or is it limited to only v2 Swagger defs ?

Thanks in advance for you answers.

4 Replies

  • KarelHusa's avatar
    KarelHusa
    Champion Level 2

    plsnrkloucast0159,

    an update to SoapUI support for OpenAPI 3.

     

    Recently, I tried to import an OpenAPI 3 definition as YAML in SoapUI 5.7.1 and suprisingly, the API has been created in SoapUI project. Though the dialogue offers JSON media type, you can use it to import the YAML file, see screenshot bellow.

     

     

    When I tried to import the same definition as JSON, it failed.

     

    In the past I did multiple tests to import OpenAPI 3 definitions into SoapUI with negative results and assume that still may be cases where the import will fail. However, at least for simpler OpenAPI 3 definitions, this works.

     

    I have summarized this in a brief article.

     

  • JuZ0's avatar
    JuZ0
    Contributor

    Great if this has been improved in 5.7.1 version.

    Also if there are some issues then a separate plugin could be coded which would allow openapi 3.x support.