Forum Discussion

Stephan58's avatar
Occasional Visitor
3 years ago

java.lang.UnsupportedClassVersionError: com/eviware/soapui/tools/JfxrtLocator

Hello everyone,

while using the new SoapUI 5.7.0 due to the log4j problem, I've tried several (Oracle) JDKs to get rid of the exception


Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/eviware/soapui/tools/JfxrtLocator has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0



According to the description Java 16 should work with soapUI 5.7.0 , but it doesn't.

I've tried Java 12, Java 15, Java 16, Java 17 without any success. I've tried with JAVA_HOME set system-wide, in in the script which starts the test.. no chance..


Does anyone know a Java Version which is working with SoapUI 5.7.0 on a Rhel System (Red Hat Enterprise Linux Server release 7.9 (Maipo))?



No RepliesBe the first to reply