Forum Discussion

yey2000's avatar
New Contributor
15 years ago

Getting unrecognized character on webservice response

I have two computers, for each of them, I am using SOAPUI 2.5.1 and 3.0.1 to test a web service. On both machines, I imported the WSDL and created test cases.

One one machine, I was able to test the web service succesfully see the response coming back correctly in both XML and Raw tab.

On the other machine, for the same web service, the response message I get has lots of unregonized characters.

--- In the Raw tab,  first part of the message is ok, but the rest is unrecognizable

HTTP/1.1 200 OK
Date: Fri, 23 Oct 2009 17:50:26 GMT

¼S]o‚0 ý+
f{€Â’E£X£ “ù‘à–ìÉ ¸ [¡¦-2÷ëW Å=墳çžsîímëN¾2†N dÊó±áX¶� y”æñØxÝ-Ì�1!®¿™nMoý6ôò 0~ ¤e¹ þâc#Qê8ÄX† dTZ:-9=Z\Äø²ÁP ±qå6ãÑù*\Ђ)â .‹n H“ñAè ]ܦ*–TB7JÞy!P( J
©ˆPÈ ¡œ+

--- In the XML tab, everything is unrecognized

�S]o�0 �+
f{� E�X� ����� � [��-2��W �=墳�s��m�N�2�N d���X�� y����x�-́1!���nMo�6�� 0~ �e� ��c#Q�8�X� dTZ:-9=Z\���P �q�6���*\Ђ)� .�n H��A� ]ܦ*�TB7J�y!P( J
��P� ��+

Any idea how to fix this, it looks like a machine dependent issue, or is there any SOAPUI preference that will parse the response message correctly.


5 Replies

  • I was a about to post a reply stating that I was having the exact same problem, but we have solved our problem, so perhaps this is solution for you also.

    My situation was the same: working on machine 1 (xml response), not working on machine 2 (strange characters in response).

    In this case the web service being called was provided by Siebel 8.1 (although that may not be important).

    After checking the HTTP headers in the "raw" tab of the XML request and response, I noticed the following in the header of the non-working request.

    Accept-Encoding: gzip,deflate

    and also this in the HTTP header of the response

    content-encoding: deflate

    The request header and response header for the working request did not have these lines.

    You can turn this off (in SOAP-UI 3.0.1) by going to HTTP Settings in the Preferences dialog (File >Preferences > HTTP Settings tab) and turning off "Accept compressed responses from host".

    Hope this helps
    • kush's avatar
      Occasional Contributor



      I am getting same issue in my Ready API. I am getting "Â" character extra in response when i am using ready API 1.9.0 but if I am using SOAPUI 4.6.0 then getting response without "Â" character.

      Not sure why this character is coming extra in ready API.


      Both of their raw request is same except User-Agent:

      In Ready API the User-Agent is: Apache-HttpClient/4.5.2 (Java/1.8.0_102)

      In SOAPUI the User-Agent is: Apache-HttpClient/4.1.1 (java 1.5)


      Can you please solve this issue.


      NOTE: I am using both Ready API and SOAPUI in same machine.

  • SmartBear_Suppo's avatar
    SmartBear Alumni (Retired)

    it looks like the message is either compressed or encrypted (or both), can you check the encryption related settings in the global http preferences?

    If that doesn't help, can you show all http headers returned with the response as shown in the RAW tab?


  • ufohunter's avatar
    New Contributor

    Did you ever get this resolved? I'm getting the same problem but only on a https WS. The same WS over http returns areadable response. I assume it is encrypted, but can't figure out how to get around it.

    Would appreciate any info on this.

  • rb's avatar
    New Contributor
    thanks dunderklumpen, that worked for me!