Forum Discussion

Dave_Braun's avatar
15 years ago

Getting Started

Hi,
I'm trying to follow the tutorial found on http://www.soapui.org/gettingstarted/mocking.html and am having a bit of trouble. First of all the suggested service (http://www.webservicex.net/CurrencyConvertor.asmx?WSDL) doesn't seem to exist anymore so I tried using
http://www.webservicex.net/convertMetri ... .asmx?wsdl instead. Everything goes find until SoapUI tried to load the WSDL and then it hangs forever. Any suggestions on how I can find out what's happening? I tried to launch the TcpMon tool but ran into problems with that but I'll leave that for another time.

D

3 Replies

  • AnandKiran's avatar
    AnandKiran
    Frequent Contributor
    Hi Braun,
                       The WSDL links which you have mention is working perfectly , check whether are you are able to view the WSDL in IE . If you are able to view the WSDL content using IE then SOAP UI will definitely upload the file .

    I think you need to specify some details in the Proxy settings under PREFERENCES . .

    I.e Go to File ->Preferences -> Proxy settings

    Under that mention the HOST name and Port details

    Kindly let me know whether my solution solves your issue or not

    Thanks
    With Regards
    Anand Kiran
  • SmartBear_Suppo's avatar
    SmartBear_Suppo
    SmartBear Alumni (Retired)
    Hi Braun,


    To me it seems that WebServiceX.NET is either not working or is working intermittently.

    My recommendation: be persistent. 
    In other words, retry loading of WSDL from your favorite browser until it responds and then "Add WSDL" from soapUI. :-)


    Cheers!
    /Nenad Nikolic a.k.a. Shonzilla